[Google Search] [Google Light Search API] Performance Degradation

Incident Report for SerpApi

Resolved

This incident has been resolved.
Posted Aug 14, 2026 - 08:52 UTC

Update

We've made improvements to Google Light Search API and the response times have decreased on our end to an average of 0.65s.
Posted Aug 04, 2026 - 23:41 UTC

Update

Response times are increasing for Google Light Search API currently. Our engineers are working on a solution.
Posted Aug 03, 2026 - 20:30 UTC

Identified

While performance improvements have been stable for the Google Light Search API, we are still seeing longer response times for the Google Search API.
Posted Jul 25, 2026 - 18:06 UTC

Monitoring

We're seeing a better response time at the moment, especially on the Google Light API
Posted Jul 24, 2026 - 05:44 UTC

Identified

We're currently experiencing an increase in response times affecting our Google Light Search API. Our engineers are working to develope a solution.
Posted Jul 20, 2026 - 21:25 UTC
This incident affected: Google (Search API) and Google Light (Search API).