Performance Degradation across APIs

Incident Report for SerpApi

Resolved

The major outage affecting multiple APIs has been resolved. Requests are now succeeding as expected, and the platform is operating normally again.

We’re very sorry for the interruption and are grateful for your patience while we worked to restore service.
Posted Mar 16, 2026 - 04:02 UTC

Update

Response times have continued to drop since the fix was implemented.
Posted Mar 15, 2026 - 23:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2026 - 19:19 UTC

Investigating

Hi there,

We're currently seeing elevated response times and error rates across APIs.

We're investigating and will provide an update as soon as we know more. Sorry for the inconvenience
Posted Mar 15, 2026 - 17:21 UTC
This incident affected: API.