[Google Images Light API] Bad images on the response

Incident Report for SerpApi

Resolved

We've made some changes we hope will prevent or minimize instances of this issue going forward.
Posted May 11, 2026 - 21:55 UTC

Identified

We're seeing bad image results on the Google Images Light API that display "the site does not have permission" text. We're currently looking for a solution to fix this.

Reference: https://github.com/serpapi/public-roadmap/issues/3346
Posted Apr 28, 2026 - 05:42 UTC
This incident affected: Google Light (Images Light API).