[Google Light Search API] Empty search results with the start pagination parameter

Incident Report for SerpApi

Monitoring

Our team has deployed fixes for an issue impacting multiple APIs. Success rates and response times are recovering. We are closely monitoring the platform to ensure stability. Some requests may still see elevated latency as systems fully recover.
Posted Jul 13, 2026 - 23:36 UTC

Investigating

We’re investigating an issue affecting the Google Light Search API in which some paginated searches using search operators may return empty results. Our team is actively working to identify the cause and restore normal functionality.

Read more here: https://github.com/serpapi/public-roadmap/issues/4023

We’ll provide another update as more information becomes available.
Posted Jul 13, 2026 - 21:32 UTC
This incident affects: Google Light (Search API).