[Instagram Profile API] Errored Responses

Incident Report for SerpApi

Resolved

We have deployed a fix and now Instagram Profile API is operating normally.
Posted Sep 07, 2026 - 06:50 UTC

Investigating

Our Instagram Profile API is currently experiencing a high level of errors.

We’re very sorry for the inconvenience and will share another update once we have more information or performance has fully stabilized.

Related issue on the Public Roadmap: https://github.com/serpapi/public-roadmap/issues/4229
Posted Sep 01, 2026 - 23:44 UTC
This incident affected: Instagram Profile API.