[Google Search API] Empty or video/image-only results for valid searches when "gl" or "hl" parameters are used

Incident Report for SerpApi

Resolved

This incident has been resolved - we are unable to reproduce it and haven't recieved any further reports. That said, be sure to reach out if you are still seeing this behavior.
Posted Apr 09, 2026 - 17:42 UTC

Monitoring

After running a few tests, we no longer see the issue appear. We'll continue monitoring the situation.
Posted Apr 08, 2026 - 13:48 UTC

Identified

As an update, we pushed a partial fix last week that should have increased the rate in which valid results are returned. We are continuing to work on a more complete solution, and will follow up when that's in place. Thanks for your patience in the meantime.
Posted Apr 07, 2026 - 17:06 UTC

Update

We're seeing multiple valid searches returning no results or returning video/image-only results. The team is currently working on a solution to restore the accuracy of search results.

Related issues:
https://github.com/serpapi/public-roadmap/issues/3645
https://github.com/serpapi/public-roadmap/issues/3500
Posted Apr 07, 2026 - 08:44 UTC

Investigating

We're seeing multiple valid searches returning no results or returning video/image-only results. The team is currently working on a solution to restore the accuracy of search results.

Related issues:
https://github.com/serpapi/public-roadmap/issues/3645
https://github.com/serpapi/public-roadmap/issues/3500
Posted Mar 24, 2026 - 08:40 UTC
This incident affected: Google (Search API) and Google Light (Search API).