[Home Depot Product API] Performance Degradation

Incident Report for SerpApi

Update

We are continuing to monitor for any further issues.
Posted Aug 19, 2026 - 22:53 UTC

Monitoring

A fix has been implemented, and the API has remained stable over the last day. We will continue monitoring the results to ensure the issue remains resolved.
Posted Aug 19, 2026 - 15:59 UTC

Identified

We're actively working on a fix. We can't share any ETA at the moment, but we will be sure to update once we have more information.
Posted Aug 17, 2026 - 08:46 UTC

Monitoring

We deployed a fix that should resolve the issue. We see recovery, but will continue monitoring.
Posted Aug 14, 2026 - 13:53 UTC

Identified

The team has identified the issue. We are working on a fix.
Posted Aug 10, 2026 - 10:03 UTC

Investigating

We are currently investigating elevated response times for our Home Depot Product API.

https://github.com/serpapi/public-roadmap/issues/4066
Posted Jul 26, 2026 - 15:31 UTC
This incident affects: The Home Depot (Product API).