[Google AI Mode] Low Success Rate

Incident Report for SerpApi

Resolved

This incident has been resolved. After making changes and monitoring performance to ensure stability, we've confirmed that the Google AI Mode API is now functioning as expected.
Posted Apr 07, 2026 - 19:38 UTC

Monitoring

We deployed a potential fix. We're currently monitoring the status.
Posted Apr 07, 2026 - 04:01 UTC

Investigating

We're currently observing a low success rate and a high response time with Google AI Mode API.

We’re very sorry for the inconvenience and will share another update once we have more information or performance has fully stabilized.

Public Roadmap issue: https://github.com/serpapi/public-roadmap/issues/3690
Posted Apr 06, 2026 - 17:51 UTC
This incident affected: Google (AI Mode API).