[Google Flights API] `deep_search` search parameter causing search timeouts

Incident Report for SerpApi

Resolved

This incident has been resolved.
Posted May 22, 2026 - 00:06 UTC

Monitoring

We have implemented a fix for the issue affecting Google Flights API searches using the `deep_search` parameter and are currently monitoring.

At this time, searches appear to be processing normally again.

Thank you for your patience while we worked to address this issue.
Posted May 21, 2026 - 04:06 UTC

Investigating

We are currently investigating an issue affecting the Google Flights API where searches using the `deep_search` parameter may timeout. At this time, the issue appears to impact the majority of requests made with this parameter enabled.

Public Roadmap:

https://github.com/serpapi/public-roadmap/issues/2749

As a temporary workaround, we recommend omitting the `deep_search` parameter.

We apologize for the inconvenience and appreciate your patience while we work on a fix.
Posted May 21, 2026 - 01:34 UTC
This incident affected: Google (Flights API).