[Google Maps Reviews API] Low success rate

Incident Report for SerpApi

Resolved

We managed to recover the API to the previous state. We'll continue monitoring the situation and will react accordingly. We apologize for the inconvenience the issue might have caused.
Posted Feb 20, 2026 - 15:31 UTC

Monitoring

We deployed a temporary fix to make it work again. However, we expect to see some missing fields on the current fix. More detail in this thread: https://github.com/serpapi/public-roadmap/issues/3548
Posted Feb 20, 2026 - 03:31 UTC

Investigating

We're seeing a low success rate from this API.

GitHub Issue: https://github.com/serpapi/public-roadmap/issues/3534
Posted Feb 18, 2026 - 06:48 UTC
This incident affected: Google (Maps Reviews API).