[eBay Search API] Degraded performance

Incident Report for SerpApi

Resolved

The performance issues affecting eBay Search API have been resolved. Response times and success rates have returned to normal levels.

We’re very sorry for the disruption this issue caused and appreciate your patience while we worked to resolve this issue.
Posted May 01, 2026 - 20:32 UTC

Investigating

We’re currently seeing increased response times, which may result in elevated timeout errors. Our team is actively investigating.

You can track updates here:

https://github.com/serpapi/public-roadmap/issues/3755
Posted Apr 30, 2026 - 20:09 UTC
This incident affected: eBay (Search API).