Performance Degradation For Some Google APIs

Incident Report for SerpApi

Resolved

Response times have returned to normal levels.

We’re very sorry for the disruption this issue caused and appreciate your patience while we worked to resolve this issue. We'll keep monitoring for any issues.
Posted Apr 13, 2026 - 23:56 UTC

Identified

We are experiencing a performance degradation that started around 3:00 AM PST, primarily affecting a couple of our Google APIs, including but not limited to Google Search API, Google Light Search API, Google Images API, Google Jobs API. Latency peaked around 8:00 AM PST.

Our team is continuing to apply optimizations to ensure latency returns to expected levels. Response times seem to be improving. We're continuing to monitor this.
Posted Apr 13, 2026 - 16:26 UTC
This incident affected: Google (Search API, Images API, Jobs API) and Google Light (Search API).