[Google Images Light API] Decreased success rate

Incident Report for SerpApi

Resolved

We're seeing the success rate is back to 100%, and it's fully operational.
Posted Feb 11, 2026 - 03:04 UTC

Monitoring

We have implemented a fix to address this issue and are continuing to monitor the situation closely.

As success rates return to normal, you may still experience intermittent increases in response times or occasional search failures.
Posted Feb 11, 2026 - 01:49 UTC

Investigating

We are currently investigating an issue causing reduced success rates for the Google Images Light API. At this time, the standard Google Images API appears unaffected and can be used as a temporary workaround while we work to resolve the issue.

We have opened an issue on our public roadmap to track progress, which you can follow here:
https://github.com/serpapi/public-roadmap/issues/3523

We apologize for the inconvenience and will share another update as soon as we have more information or once performance has fully stabilized.
Posted Feb 11, 2026 - 00:48 UTC
This incident affected: Google Light (Images Light API).