[Google Shopping Light API] Performance Degradation

Incident Report for SerpApi

Identified

The issue occurred due to changes from Google's side. We've made some temporary adjustements that should resolve the problem for the majority of APIs. Response times and success rates should be improving. Google Shopping and Google Shopping Light APIs may still be degraded or not function as expected. Thanks for your continued patience as we work toward a full resolution.
Posted Feb 24, 2026 - 22:32 UTC

Investigating

We're currently experiencing elevated response times for most APIs, and reduced success rates on some.

The Google Shopping Light API appears most affected.

We're still investigating and will follow up when we have more information. Thanks for your patience in the meantime.
Posted Feb 24, 2026 - 18:26 UTC
This incident affects: API and Google Light (Shopping Light API).