[Google News API] Degraded Performance

Incident Report for SerpApi

Resolved

We've deployed a fix. We're seeing a normal performance from Google News API now.
Posted Sep 07, 2026 - 05:02 UTC

Investigating

We notice that Google News' success rate is decreasing. Some searches may still be successful, but the average response time is high.

Related issue on GitHub: https://github.com/serpapi/public-roadmap/issues/4241
Posted Sep 05, 2026 - 03:03 UTC
This incident affected: Google (News API).