[Walmart Product API] Performance Degradation

Incident Report for SerpApi

Investigating

We see another performance degradation with the Walmart Product API. We're investigating the issue.
Posted May 14, 2026 - 10:54 UTC

Monitoring

A fix has been implemented. We are monitoring the results.
Posted May 06, 2026 - 15:23 UTC

Investigating

We’re seeing elevated response times again for the Walmart Product API. Our engineering team is investigating and working to restore normal performance.

Public Roadmap issue: https://github.com/serpapi/public-roadmap/issues/3739
Posted Apr 30, 2026 - 14:17 UTC
This incident affects: Walmart (Product API).