[Home Depot Product API] Some searches time out

Incident Report for SerpApi

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 18:33 UTC

Update

This issue has been resolved.
Posted Mar 20, 2026 - 18:32 UTC

Identified

We've been seeing better results since 10 days ago. We're still working on a fix.
Posted Mar 16, 2026 - 05:30 UTC

Investigating

We’re currently investigating the issue of some searches timing out for the Home Depot Product API.

https://github.com/serpapi/public-roadmap/issues/3422
Posted Mar 03, 2026 - 00:07 UTC
This incident affected: The Home Depot (Product API).