Performance degradation across all APIs and websites

Incident Report for SerpApi

Resolved

This incident has been resolved 🥳.

Thank you all for your patience, and we sincerely apologize for any inconvenience caused.
Posted Apr 07, 2026 - 14:56 UTC

Identified

The issue has been identified, and we're working on it.
Posted Apr 07, 2026 - 14:00 UTC

Investigating

Hi there,

We're currently seeing elevated response times and error rates across APIs.

We're investigating and will provide an update as soon as we know more. Sorry for the inconvenience

Public Github issue: https://github.com/serpapi/public-roadmap/issues/3692
Posted Apr 07, 2026 - 13:54 UTC
This incident affected: API and Website.