This incident has been resolved, and performance across our APIs is no longer degraded.
You may still notice slightly longer response times for the Google Images Light API compared to levels observed prior to this incident. This is due to changes on Google’s side. While there is no immediate solution available, we are actively monitoring the situation and continuing to evaluate potential improvements.
Thank you for your patience, and please don’t hesitate to reach out if you have any questions.
Posted Feb 12, 2026 - 22:40 UTC
Monitoring
We have seen response times return to normal and are currently monitoring. You may still experience slightly increased response times as performance stabilizes.
We will continue to monitor the situation closely and will provide another update once we’re confident the issue is fully resolved.
Posted Feb 11, 2026 - 22:33 UTC
Investigating
We are currently investigating an increase in response times across all of our APIs. Success rates don't as of now seem to be affected. This is documented at https://github.com/serpapi/public-roadmap/issues.
We'll reach out with an update when we have more information. Thanks for your patience in the meantime.