[Home Depot API] Unstable success rate and response time

Incident Report for SerpApi

Resolved

The performance issues affecting Home Depot API. have been resolved. Response times and success rates have returned to normal levels.

We’re very sorry for the disruption this issue caused and appreciate your patience while we worked to resolve this issue.
Posted Mar 16, 2026 - 04:05 UTC

Update

The response time is spiking again and we are investigating.
Posted Mar 15, 2026 - 23:23 UTC

Monitoring

Our team has deployed changes to address the performance degradation affecting Home Depot API, and we are seeing success rates and response times return to normal. We are continuing to monitor closely.
Posted Mar 13, 2026 - 00:02 UTC

Identified

Due to high fluctuations, response times and success rates may be low for the Home Depot API. We are actively working on a solution to address this issue.

https://github.com/serpapi/public-roadmap/issues/3575
Posted Mar 04, 2026 - 17:08 UTC
This incident affected: The Home Depot (Search API).