[Google Maps Photos API] Searches timing out

Incident Report for SerpApi

Resolved

The issue affecting Google Maps Photos API has been resolved.

We’re very sorry for any disruption and appreciate your patience while we worked to resolved this issue.
Posted May 05, 2026 - 23:01 UTC

Monitoring

A fix has been implemented and we're monitoring the performance.
Posted May 05, 2026 - 09:54 UTC

Investigating

We are currently investigating an issue causing increased response times and timeouts for the Google Maps Photos API.

We apologize for the disruption and will provide an update as soon as we have more information or once performance has stabilized.
Posted May 04, 2026 - 20:34 UTC
This incident affected: Google (Maps Photos API).