[Walmart Product API] Performance Degradation

Incident Report for SerpApi

Resolved

The issue was identified at a fix was released.
Posted Apr 30, 2026 - 07:19 UTC

Identified

The issue has been identified, and a preliminary fix is being tested.
Posted Apr 23, 2026 - 06:14 UTC

Investigating

We’re currently seeing elevated response times and a decrease in success rates for Walmart Product API. Our engineering team is investigating and working to restore normal performance.

Public Roadmap issue: https://github.com/serpapi/public-roadmap/issues/3739
Posted Apr 22, 2026 - 07:57 UTC
This incident affected: Walmart (Product API).