Performance Degradation

Incident Report for SerpApi

Resolved

The performance has been stable for the past few days after we made some changes internal changes. We'll continue monitoring and making adjustments. This issue is considered resolved now.
Posted Jul 12, 2026 - 11:59 UTC

Monitoring

We're seeing a better performance for hours. However, we're still monitoring the situation.
Posted Jul 08, 2026 - 06:13 UTC

Identified

Our engineers identified the cause of the current performance degradation within an upstream component of our infrastructure. We are actively implementing improvements to stabilize performance across affected APIs.
Posted Jul 07, 2026 - 18:16 UTC

Investigating

We're currently investigating longer response times and lower success rates across APIs.
Posted Jul 07, 2026 - 15:46 UTC
This incident affected: API, Bing (Search API), Google Light (Images Light API), and Google (Lens API, Local API).