[Home Depot API] Performance Degradation

Incident Report for SerpApi

Resolved

We've released a fix restoring the performance. Thank you for your patience.
Posted Sep 21, 2026 - 12:29 UTC

Update

We’re working on a fix, which is currently under review. We apologize for the wait and will share an update as soon as the issue is resolved.

We appreciate your continued patience and understanding.
Posted Sep 19, 2026 - 23:21 UTC

Identified

We observed degraded performance again and the team has identified the issue. We are actively working on implementing a fix.
Posted Sep 11, 2026 - 03:57 UTC

Update

We are continuing to monitor for any further issues.
Posted Aug 19, 2026 - 22:53 UTC

Monitoring

A fix has been implemented, and the API has remained stable over the last day. We will continue monitoring the results to ensure the issue remains resolved.
Posted Aug 19, 2026 - 15:59 UTC

Update

We're actively working on a fix. We can't share any ETA at the moment, but we will be sure to update once we have more information.
Posted Aug 17, 2026 - 08:46 UTC

Identified

We started degrading again. The team has identified the issue. We are working on a fix.
Posted Aug 14, 2026 - 20:54 UTC

Monitoring

We deployed a fix that should resolve the issue. We see recovery, but will continue monitoring.
Posted Aug 14, 2026 - 13:53 UTC

Identified

The team has identified the issue. We are working on a fix.
Posted Aug 10, 2026 - 10:03 UTC

Investigating

We're seeing a very low success rate on the Home Depot API.
GitHub issue: https://github.com/serpapi/public-roadmap/issues/4106
Posted Aug 01, 2026 - 03:25 UTC
This incident affected: The Home Depot (Search API).