[Google Search API] Searches with advanced operators time out intermittently

Incident Report for SerpApi

Update

Queries with advanced search operators may also be returning an HTTP 500 error:

https://github.com/serpapi/public-roadmap/issues/4213

We're continuing to work toward a fix. Thank you for your patience in the meantime.
Posted Aug 29, 2026 - 19:51 UTC

Identified

We've been experiencing issues with Google Search API executing very slowly or timing out entirely when advanced search operators are used in query. We've identified the issue and are currently working on a fix.

https://github.com/serpapi/public-roadmap/issues/4080
Posted Aug 26, 2026 - 14:33 UTC
This incident affects: Google (Search API).