Decreased success rate

Incident Report for SerpApi

Resolved

The issue causing failed Google Images Light API requests has been fully resolved. Requests are now succeeding as expected and the API is operating normally.

You can view additional details here:
https://github.com/serpapi/public-roadmap/issues/3331#event-21530394410

We’re very sorry for the interruption and are grateful for your patience while we worked to restore service.
Posted Dec 12, 2025 - 03:30 UTC

Update

We are continuing to monitor for any further issues.
Posted Dec 12, 2025 - 01:37 UTC

Monitoring

We have implemented a fix to resolve this issue. We are continuing to monitor closely.

While success rates have returned to expected levels, you may continue to experience elevated response times.
Posted Dec 12, 2025 - 01:37 UTC

Investigating

We are currently investigating an issue that is causing requests to the Google Images Light API to fail.

You can follow progress here:
https://github.com/serpapi/public-roadmap/issues/3331

We’re very sorry for the inconvenience and will share another update once we have more information or performance has fully stabilized.
Posted Dec 11, 2025 - 18:00 UTC
This incident affected: API.