[Google AI Mode API] Performance Degradation

Incident Report for SerpApi

Resolved

The performance remained stable outside of a couple of incidents, which were more general rather than Google AI Mode API-specific.
Posted Jul 04, 2026 - 08:55 UTC

Monitoring

We're seeing 100% success rate since yesterday with some small hiccups. We're still monitoring the situation.
Posted Jun 28, 2026 - 22:33 UTC

Update

We are continuing to investigate this issue.
Posted Jun 24, 2026 - 22:41 UTC

Investigating

The Google AI Mode API is currently experiencing reduced success rates and increased response times.

We’re very sorry for the inconvenience and will share another update once we have more information or performance has stabilized.
Posted Jun 24, 2026 - 22:40 UTC
This incident affected: Google (AI Mode API).