[eBay Search API] Performance degradation

Incident Report for SerpApi

Resolved

We've deployed a fix, and the response times are back to normal.
Posted Apr 28, 2026 - 11:08 UTC

Monitoring

The response time seems back to usual at the moment. We'll continue to monitor the performance.
Posted Apr 28, 2026 - 02:18 UTC

Investigating

We're seeing increased response times leading to increased time out errors as well. We're investigating.

https://github.com/serpapi/public-roadmap/issues/3755
Posted Apr 27, 2026 - 09:02 UTC
This incident affected: eBay (Search API).