[Google APIs] performance degradation

Incident Report for SerpApi

Update

We are continuing to work on a fix for this issue.
Posted Jul 15, 2026 - 22:52 UTC

Identified

Google Light response times have returned to normal. However, some responses may still return empty results, as documented here: https://github.com/serpapi/public-roadmap/issues/4032.

You may also continue to experience elevated response times across some of our Google-based APIs.

This issue is related to recent changes from Google, as well as an issue affecting one or more of our upstream service providers.

Our engineers are actively working on a fix, and we'll continue to provide updates as progress is made.
Posted Jul 15, 2026 - 22:37 UTC

Investigating

We're investigating another increase in response times, most significantly affecting the Google Light Search API but also affecting other Google APIs.
Posted Jul 14, 2026 - 21:25 UTC

Monitoring

We saw a decrease in success rates and slower response times on several, but not all, Google-related APIs. We've deployed a fix, and are currently monitoring the issue

GitHub issue: https://github.com/serpapi/public-roadmap/issues/4025
Posted Jul 14, 2026 - 05:29 UTC
This incident affects: Google (Search API, AI Mode API, Forums API, Images API, Immersive Product API, Local API, Shopping API) and Google Light (Search API, Images Light API, Shopping Light API).