[Home Depot API] [Home Depot Product API] Performance Degradation

Incident Report for SerpApi

Resolved

The performance issues affecting Home Depot API & Home Depot Product API have been resolved. Response times and success rates have returned to normal levels.

We’re very sorry for the disruption this issue caused and appreciate your patience while we worked to resolve this issue.
Posted Jul 03, 2026 - 23:23 UTC

Monitoring

We've deployed a temporary fix about a week ago for Home Depot API and Home Depot Product API. Response times and success rates are back to normal. We are continuing to work on a more permanent solution, that we aim to roll out in the coming weeks.

Thanks for your patience and understanding as we work through this.
Posted Jul 02, 2026 - 00:11 UTC

Investigating

We're currently investigating elevated responses times, decreased success rates, and ocassional empty results affecting the Home Depot API and Home Depot Product API.
Posted Jun 18, 2026 - 20:01 UTC
This incident affected: The Home Depot (Search API, Product API).