Resolved
Response times and success rates have returned to normal levels.
We’re very sorry for the disruption this issue caused and appreciate your patience while we worked to resolve this issue. We'll keep monitoring for any issues.
Posted May 22, 2026 - 00:00 UTC
Update
We are continuing to monitor for any further issues.
Posted May 21, 2026 - 21:40 UTC
Monitoring
We've implemented a fix and are seeing response time and success rates recover. We are currently monitoring. Please feel free to reach out to us at contact@serpapi.com if you continue to face any issues.
Posted May 21, 2026 - 21:38 UTC
Investigating
We’re currently experiencing a major outage affecting multiple Google APIs. A large number of requests are failing or timing out. Our engineering team is actively investigating and treating this as our top priority.
Public Roadmap Issue: https://github.com/serpapi/public-roadmap/issues/3846
Posted May 21, 2026 - 21:01 UTC
This incident affected: API, Google (Search API, Ads Transparency API, AI Mode API, AI Overview API, Autocomplete API, Events API, Forums API, Finance API, Finance Markets API, Flights API, Flights Autocomplete API, Hotels API, Hotels Reviews API, Hotels Photos API, Images API, Immersive Product API, Jobs API, Lens API, Local API, Local Services API, Maps API, Maps Reviews API, News API, Patents API, Play Store API, Related Questions API, Reverse Image API, Scholar API, Shopping API, Short Videos API, Travel Explore API, Trends API, Videos API, Scholar Case Law API, Maps Photos API), and Google Light (Search API, Images Light API, News Light API, Shopping Light API, Videos Light API).