[Google Trends API] Performance degradation

Incident Report for SerpApi

Resolved

The issue has been resolved and the performance is stable for the past week.
Posted Aug 10, 2026 - 10:06 UTC

Monitoring

The performance is stable now. We'll continue monitoring.
Posted Aug 01, 2026 - 15:55 UTC

Investigating

We are currently investigating elevated response times for our Google Trends API.

https://github.com/serpapi/public-roadmap/issues/4086
Posted Jul 29, 2026 - 11:06 UTC
This incident affected: Google (Trends API).