[Yandex Images API] Performance Degradation

Incident Report for SerpApi

Resolved

We have implemented a fix. The performance issues affecting Yandex Images API have been resolved. Response times and success rates have returned to normal levels.

We’re very sorry for the disruption this issue caused and appreciate your patience while we worked to resolve this issue. Please feel free to reach out to us at contact@serpapi.com if you encounter any further issues.
Posted May 04, 2026 - 20:10 UTC

Identified

We have identified the cause of the performance degradation. Our team is actively working on improvements to reduce latency and restore normal success rates.
Posted May 01, 2026 - 17:55 UTC

Investigating

We’re currently seeing elevated response times and a decrease in success rates for Yandex Images API. Our engineering team is investigating and working to restore normal performance.

Public Roadmap issue: https://github.com/serpapi/public-roadmap/issues/3772
Posted Apr 30, 2026 - 20:04 UTC
This incident affected: Yandex (Images API).