[Google Search API] Organic results full with video or image content

Incident Report for SerpApi

Resolved

The issue is no longer reproducible at this time. We will continue to monitor the situation.
Posted Feb 09, 2026 - 11:06 UTC

Monitoring

We are seeing success rates and response times return to normal. We are continuing to monitor closely.
Posted Feb 05, 2026 - 11:43 UTC

Identified

We've identified the root cause of the issue.

This appears to be due to changes from Google's side. Our engineers are working on a solution, and we'll follow up again once that's been implemented.
Posted Feb 03, 2026 - 18:38 UTC

Investigating

We received a couple of reports from our users that Google Search API results are often populated with only YouTube videos. We're investigating the issue.

https://github.com/serpapi/public-roadmap/issues/3500
Posted Feb 03, 2026 - 11:52 UTC
This incident affected: Google (Search API).