[Google Finance API] Performance degradation

Incident Report for SerpApi

Update

We’re currently experiencing a major outage affecting Google Finance API and Google Finance Markets API. A large number of requests are failing or timing out. We have prioritized this issue and our engineering team is actively investigating.

Related Issues on our Public Roadmap:
https://github.com/serpapi/public-roadmap/issues/3769
https://github.com/serpapi/public-roadmap/issues/3765
Posted May 05, 2026 - 21:48 UTC

Investigating

We're seeing higher than normal response times on the Google Finance API and Google Finance Markets API. We're investigating.
Posted Apr 30, 2026 - 15:06 UTC
This incident affects: Google (Finance API, Finance Markets API).