[Amazon Product API] Decreased Success Rate

Incident Report for SerpApi

Identified

While error rates remain slightly elevated, we have seen a large increase in the number of successful searches. We are working to bring these rates back to expected values.

We appreciate your continued patience while we work toward full resolution.

Public Roadmap issue: https://github.com/serpapi/public-roadmap/issues/3701
Posted Apr 10, 2026 - 00:58 UTC

Investigating

We're seeing a drop again in the success rate for Amazon Product API, and we are investigating it. We’re very sorry for the inconvenience and we will share another update once we have more information.
Posted Apr 09, 2026 - 21:56 UTC

Monitoring

Our team has deployed changes to address the performance degradation affecting Amazon Product API, and we are seeing success rates return to normal. We are continuing to monitor closely.
Posted Apr 08, 2026 - 22:03 UTC

Identified

Our team has identified the issue and deployed a fix.

We're monitoring and working on a couple other changes to bring the success rate back to normal. We will provide an update once the issue is resolved.
Posted Apr 08, 2026 - 20:00 UTC

Investigating

We're currently observing a low success rate for Amazon Product API.

We’re very sorry for the inconvenience and will share another update once we have more information or performance has fully stabilized.

Public Roadmap issue: https://github.com/serpapi/public-roadmap/issues/3694
Posted Apr 08, 2026 - 16:40 UTC
This incident affects: Amazon (Product API).