Performance degradation across many Google APIs

Incident Report for SerpApi

Resolved

This is resolved. Thank you for your patience while we worked on this.
Posted Aug 09, 2026 - 13:26 UTC

Monitoring

Hi there,

Our engineering team has deployed an additional fix, and performance has improved. We're continuing to monitor the situation closely before considering the issue fully resolved.

We sincerely apologize for the disruption and appreciate your patience while we work to ensure stability.
Posted Aug 08, 2026 - 21:06 UTC

Investigating

We're seeing increased response times again. We're investigating.
Posted Aug 08, 2026 - 10:37 UTC

Monitoring

Our team has released a fix, and success rates and response times have returned to expected levels for most Google APIs. A few services are still recovering, and you may experience increased response times as performance returns to normal.

We continue to monitor the issue.
Posted Aug 08, 2026 - 00:57 UTC

Investigating

We’re currently experiencing an outage affecting multiple APIs. A large number of requests are failing or timing out. Our engineering team is actively investigating and treating this as our top priority.

https://github.com/serpapi/public-roadmap/issues/4129
Posted Aug 07, 2026 - 20:57 UTC
This incident affected: API, Google (Search API, Ads Transparency API, AI Mode API, AI Overview API, Autocomplete API, Events API, Forums API, Finance API, Finance Markets API, Flights API, Flights Autocomplete API, Flights Deals API, Hotels API, Hotels Reviews API, Hotels Photos API, Images API, Immersive Product API, Jobs API, Lens API, Local API, Local Services API, Maps API, Maps Reviews API, News API, Related Questions API, Reverse Image API, Scholar API, Shopping API, Short Videos API, Travel Explore API, Trends API, Videos API, Scholar Case Law API, Maps Photos API), and Google Light (Images Light API, News Light API, Shopping Light API, Videos Light API).