[Google Search API] Performance Degradation

Incident Report for SerpApi

Resolved

The issue have been resolved. Response times have returned to normal levels.

We’re very sorry for the impact this issue caused and appreciate your patience while we worked to resolve it.
Posted Apr 09, 2026 - 21:27 UTC

Monitoring

We experienced a performance degradation starting around 5:00 AM PST, primarily affecting our Google Search and Google Search Light APIs. Latency peaked around 7:00 AM PST.

Our team is continuing to apply optimizations to ensure latency returns to expected levels. Response times have been steadily improving since then. We're continuing to monitor this.
Posted Apr 09, 2026 - 18:17 UTC
This incident affected: Google (Search API) and Google Light (Search API).