Google Related APIs Performance Degradation

Incident Report for SerpApi

Resolved

We've made some internal adjustments and have seen much better performance for the past few days. We'll continue monitoring the situation. We consider this issue resolved.
Posted Jul 12, 2026 - 12:00 UTC

Investigating

We are currently investigating this issue.
Posted Jul 06, 2026 - 16:58 UTC

Identified

We're seeing another increase in response times this morning, most noticibly affecting our Google Shopping API. We're investigating and will follow up with any updates. Thank you for your continued patience.
Posted Jul 06, 2026 - 16:57 UTC

Monitoring

Good news! We deployed a fix, and we're seeing recovery. Our engineering team is continuing to monitor the situation closely and make adjustments to fully restore normal performance.

We appreciate your patience and will keep you updated as we have more information.

Thank you for your understanding.
Posted Jul 05, 2026 - 19:31 UTC

Investigating

We're seeing increased response times across several Google-related APIs since the last hour. We're investigating
Posted Jul 05, 2026 - 18:13 UTC

Monitoring

We're seeing improved response time and stability for the past couple of hours. We'll continue monitoring the performance.
Posted Jul 04, 2026 - 08:21 UTC

Update

We are continuing to investigate this issue.
Posted Jul 03, 2026 - 15:44 UTC

Investigating

We're seeing higher than normal response times on several, but not all, Google related APIs.

https://github.com/serpapi/public-roadmap/issues/3972
Posted Jul 03, 2026 - 15:43 UTC
This incident affected: Google (Search API, Ads Transparency API, AI Mode API, AI Overview API, Autocomplete API, Events API, Forums API, Finance API, Finance Markets API, Flights API, Flights Autocomplete API, Flights Deals API, Hotels API, Hotels Reviews API, Hotels Photos API, Images API, Immersive Product API, Jobs API, Lens API, Local API, Local Services API, Maps API, Maps Reviews API, News API, Patents API, Play Store API, Related Questions API, Reverse Image API, Scholar API, Shopping API, Short Videos API, Travel Explore API, Trends API, Videos API, Scholar Case Law API, Maps Photos API) and Google Light (Search API, Images Light API, News Light API, Shopping Light API, Videos Light API).