[Yelp Place API] High average response time

Incident Report for SerpApi

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 01:05 UTC

Investigating

We're currently investigating the issue of higher respose time on the Yelp Place API

https://github.com/serpapi/public-roadmap/issues/3568
Posted Mar 02, 2026 - 23:50 UTC
This incident affected: Yelp (Place API).