[Baidu News API] Performance Degradation

Incident Report for SerpApi

Update

We are still investigating the cause of this issue. Response times have returned to baseline.
Posted Apr 14, 2026 - 02:26 UTC

Investigating

We’re currently seeing elevated response times for Baidu News API. Our engineering team is investigating and working to restore normal performance.

Public Roadmap issue: https://github.com/serpapi/public-roadmap/issues/3709
Posted Apr 13, 2026 - 18:35 UTC
This incident affects: API.