[eBay Search API] Performance Degradation

Incident Report for SerpApi

Identified

We've identified that the performance has been worse due to the Sold and Complete filters being hidden behind a login, making API calls with these timeout, decreasing the overall success rate.
Posted Aug 01, 2026 - 15:44 UTC

Investigating

Our eBay Search API is currently experiencing a low success rate and high response times.

We’re very sorry for the inconvenience and will share another update once we have more information or performance has fully stabilized.

https://github.com/serpapi/public-roadmap/issues/4063
Posted Jul 23, 2026 - 22:21 UTC
This incident affects: eBay (Search API).