Performance degradation across many Google APIs

Incident Report for SerpApi

Resolved

We will be closing this issue, as we have opened more specific incidents with additional information:

- Google News Result Timeouts: https://status.serpapi.com/incidents/6chb6clhbgw4
- Advanced Search Operator Timeouts: https://status.serpapi.com/incidents/pts4x92phsq8

Thank you for your patience while we work to resolve these outstanding issues.
Posted Sep 10, 2026 - 18:35 UTC

Investigating

We're currently seeing elevated response times across Google APIs, including Google Search API, Google Shopping API, Google News Light API, Google Jobs API, and others.

Related issue on our Public Roadmap: https://github.com/serpapi/public-roadmap/issues/4240
Posted Sep 08, 2026 - 15:58 UTC

Monitoring

Quick update: We've deployed a fix for this. We're actively monitoring the performance.

Thank you for your patience while we work on this.
Posted Sep 06, 2026 - 17:40 UTC

Identified

We’ve identified the likely cause and are actively testing several potential fixes.

We appreciate your patience and will share another update as soon as we have more information.
Posted Sep 05, 2026 - 00:17 UTC

Investigating

We apologize for the impact. We're currently seeing elevated response times and error rates across many Google APIs including Google Light Search API, Google Shopping API, Google News Light API, Google Jobs API and others.

Related issue on our Public Roadmap: https://github.com/serpapi/public-roadmap/issues/4240
Posted Sep 04, 2026 - 21:27 UTC
This incident affected: API, Google (Search API, Jobs API, Shopping API), and Google Light (Search API, News Light API).