[Google Search API][Google Light Search API] Elevated Response Times

Incident Report for SerpApi

Resolved

We will be closing this issue, as we have opened more specific incidents with additional information:

- Google News Result Timeouts: https://status.serpapi.com/incidents/6chb6clhbgw4
- Advanced Search Operator Timeouts: https://status.serpapi.com/incidents/pts4x92phsq8

Thank you for your patience while we work to resolve these outstanding issues.
Posted Sep 10, 2026 - 18:53 UTC

Update

We are continuing to investigate this issue.
Posted Sep 10, 2026 - 18:44 UTC

Investigating

We are currently investigating an increase in response times affecting the Google Search API and Google Light Search API, starting around 9:00 UTC this morning. Since 14:00 UTC we have been seeing signs of improvement.
Posted Aug 31, 2026 - 17:14 UTC
This incident affected: Google (Search API) and Google Light (Search API).